All services have been tested and are operating normally. The earlier SMS delivery issue has been resolved and the incident is now closed. We’ll continue light monitoring.
If you notice anything unusual, please contact support. Thank you for your patience.
Posted Sep 17, 2025 - 09:53 SAST
Monitoring
The earlier delays and intermittent delivery from our upstream SMS providers have been resolved. Message traffic is flowing normally and we’re actively monitoring to ensure stability.
If you notice any further issues, please let us know. We’ll share additional details if anything changes. Thank you for your patience.
Posted Sep 17, 2025 - 09:48 SAST
Investigating
We’re experiencing delays and intermittent delivery from our upstream SMS providers. Our team is actively investigating with the vendors and working to restore normal service. No action is required on your side. We’ll share further updates as soon as possible. Apologies for the inconvenience.